How bad is it.........?
Results 1 to 7 of 7

Thread: How bad is it.........?

  1. #1
    Registered User Array SKillerspeed's Avatar
    Join Date
    Jul 2009
    Location
    Richmond
    Bike
    GSX-R 600 K4; DRZ 400SM K5; GSX-R 600 K8

    Question How bad is it.........?

    I got the c28 code, diagnosed it, and am now waiting for a new ECU (EVERYTHING else works just fine except for the ECU)
    In the meantime, how bad could it be to run with the secondaries stuck @ about 30-50% open?

    It feels fine, that is, I don't notice any difference since before the code. It accelerates the same and fuel economy is unchanged.
    *Maritimer For Life*

  2. Remove Advertisements
    BCSportBikes.com
    Advertisements
     

  3. #2
    Registered User Array 125cbr rider's Avatar
    Join Date
    Jul 2008
    Location
    Coquitlam
    Bike
    2014 Honda CB500X
    sounds like your bike is MUFFED up. check suzuki forums.

  4. #3
    Registered User Array SKillerspeed's Avatar
    Join Date
    Jul 2009
    Location
    Richmond
    Bike
    GSX-R 600 K4; DRZ 400SM K5; GSX-R 600 K8
    Quote Originally Posted by 125cbr rider View Post
    sounds like your bike is MUFFED up. check suzuki forums.
    Thanks! You're advice is Amazingly helpful

    No replies from Scooter riders please...
    *Maritimer For Life*

  5. #4
    Registered User Array 125cbr rider's Avatar
    Join Date
    Jul 2008
    Location
    Coquitlam
    Bike
    2014 Honda CB500X
    from some searching. Riding with the error. as one member on the forums said "Your bike will run in failsafe mode. It will ignore the input from the atmospheric sensors and will not run to it's potential."

    I'd only ride it to where ever its getting fixed. hope that helped some more...

  6. #5
    Moderator Array Mighty Kentor's Avatar
    Join Date
    Mar 2004
    Location
    Mission, BC
    Bike
    2004 R1, 2005 DL1000 V-Strom
    Quote Originally Posted by mgmtgal01 View Post
    Thanks! You're advice is Amazingly helpful

    No replies from Scooter riders please...
    Meow!

    Actually Suzuki forums would be the way to go. gixxer.com would be a good start.
    Reformatted to fit your screen.

  7. #6
    Registered User Array SKillerspeed's Avatar
    Join Date
    Jul 2009
    Location
    Richmond
    Bike
    GSX-R 600 K4; DRZ 400SM K5; GSX-R 600 K8
    Actually turned out to NOT be the ECU

    I think it's a fuel pump problem now...
    *Maritimer For Life*

  8. #7
    Registered User Array SKillerspeed's Avatar
    Join Date
    Jul 2009
    Location
    Richmond
    Bike
    GSX-R 600 K4; DRZ 400SM K5; GSX-R 600 K8
    SOLUTION!

    Just in case anyone is searching this issue in the future...

    Finally got it fixed. The fuel pump was crap and was not giving reliable output before finally dying all together (explains the surging issues) along with some corroded, crossed wires that were actually arching off one another (probably causing the series of error codes).
    A combination of issues... leading to many different diagnosis.
    *Maritimer For Life*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •