No neutral light/bike won't start.
Results 1 to 6 of 6

Thread: No neutral light/bike won't start.

  1. #1
    Registered User Array
    Join Date
    Apr 2006
    Location
    N Van
    Bike
    2001 r6

    No neutral light/bike won't start.

    I have a 98 Yamaha r1 that won't start. My neutral light won't come on but I know the bike is in neutral. Starter won't go either. The lights, display that kind of stuff comes on but other than that nothing. Anybody help me out?

  2. Remove Advertisements
    BCSportBikes.com
    Advertisements
     

  3. #2
    Vale Tudo Array Vili's Avatar
    Join Date
    Feb 2006
    Location
    Lower Mainland
    Bike
    I got a gun ...
    does it turn at all? if not at all, check the fuse. If it turns but does not have power to start the engine then battery is drained.

  4. #3
    Moderator Array TeeTee's Avatar
    Join Date
    Feb 2002
    Location
    Out to pasture in the 'Wack
    Bike
    04 Kawi Z1000,
    Your neutral sensor switch is busted or the wire got ripped off or something like that. You need to fix that switch or the wire to it before it'll go. The fact the neutral light doesn't come on in conjunction with the no starter thing is a dead giveaway.
    A backyard mechanic without a service manual is just like a hooker without a lamp pole.... they are both in the dark.

  5. #4
    Registered User Array
    Join Date
    Apr 2006
    Location
    N Van
    Bike
    2001 r6
    Ya, thats what I think it is too, neutral switch has kicked the bucket. Does anybody know how much it cost for a new one?

  6. #5
    ssblade
    Guest
    will it start with the kickstand up and the clutch pulled in?

  7. #6
    doug
    Guest
    look it up on www.bikebandit.com

    it will be us prices, but it gives you a decent ballpark.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •