BC Sport Bikes Forum banner

1 - 4 of 4 Posts

·
umm... yeah
Joined
·
203 Posts
Discussion Starter #1
hey guys,

I just got home from riding tonight and noticed i've got oil all over the rear of the right side of my bike (including tire and brakes). I cleaned it all off and started the bike up to see if i could pinoint the leak. well it worked. Where my clutch cable attatches to the shaft, there is a rubber seal. It had worked it's way partially out and the oil was bubbling out from around it. I pushed it back in and the leak stopped. Is the seal a pressure release to save other components or has anyone had to replace the seal due to wear? Now it's leaking from the outside of the seal where it sits in the engine cover, not from where the shaft goes through.

Matt
 

·
Registered
Joined
·
2,673 Posts
thats a odd place,but just make sure the crank vent is working and not pinched off or blocked,or it will blow out the weakest seal point.other wise leave ot if its not leaking again.
 

·
umm... yeah
Joined
·
203 Posts
Discussion Starter #3
hey,

thanks for the reply, i'm pretty sure thats what i'll do. Just keep an eye on it for the next little while. It was pretty strange, thank god i didn't take any hard right turns on the way home

Matt
 

·
umm... yeah
Joined
·
203 Posts
Discussion Starter #4
for anyone following this, problem is solved. When I installed my velocity stacks and throttle stops I left my PVC hose off and it pinched so no air could excape. The buildup of pressure pushed the seal out of the clutch cover. All is well now

matt
 
1 - 4 of 4 Posts
Top