BC Sport Bikes Forum banner

1 - 14 of 14 Posts
K

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Funny story...

So I've been having FI problems with my gixxer but it doesn't do anything except for the light coming on. I've brought it to a couple dealerships and they say they can't do anything for me because the error code wasn't saved. So I finally pick up my bike yesterday from the last dealership and got about 2 blocks and the light goes on! Ran back, they plugged it in and finally found the problem. Thank goodness cause that light was driving me nuts... but at least the finally found the problem.

Anyone else have problems with the FI light on their gixxers?
 

·
CrazyAssFlip
Joined
·
787 Posts
kelly said:
Funny story...

So I've been having FI problems with my gixxer but it doesn't do anything except for the light coming on. I've brought it to a couple dealerships and they say they can't do anything for me because the error code wasn't saved. So I finally pick up my bike yesterday from the last dealership and got about 2 blocks and the light goes on! Ran back, they plugged it in and finally found the problem. Thank goodness cause that light was driving me nuts... but at least the finally found the problem.



Anyone else have problems with the FI light on their gixxers?
did they tell u what problem it was?
 

·
Resident Banana
Joined
·
2,694 Posts
Hey kelly...welcome to the board :flip .

I've had an error code C28 or something like that come up on mine. Turned out to be the cable from the stepper motor to the secondary butterfly frayed and broke. It didn't hamper performance very much and was fixxed pretty quick.

What was the error code that they got?

atom
 

·
Registered
Joined
·
4,209 Posts
CG ?? you want to share some of your FI problems ? :D:D:D:D like my signature says....lol, how you doing CG ? haven't heard much from you, got the race bodywork ? post some pictures...
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Yeah I told them all about it but there wasn't anything they could do (until I went back with the light on). It was a C28 as well... but I've also been getting some bad throttle response and maybe some ticking noises too. Can't be sure about the noise though.
 

·
Super Moderator
Joined
·
5,114 Posts
my bike is still running. makes that weird noise still for some unknown reason. seems to be coming from the front wheel.

anyhow back to the FI light. I never had a problem with it until the past 3 weeks where it has come on at least 6 times, everytime I shut the bike off and turn it back on it goes off. There was a recall on this I believe, or not a recall but a dealer notice where they replace the STC Unit under warranty because it creates false readings every now and then. I should get take my bike in to get this part replaced.

here is a copy of the bulletin that all suzuki dealers should have got.

http://www.gsxr750.org/images/600/600bulletin/600bulletin1.jpg

http://www.gsxr750.org/images/600/600bulletin/600bulletin2.jpg
 

·
Resident Banana
Joined
·
2,694 Posts
kelly said:
Yeah I told them all about it but there wasn't anything they could do (until I went back with the light on). It was a C28 as well... but I've also been getting some bad throttle response and maybe some ticking noises too. Can't be sure about the noise though.
They'rejust gonna replace the cable and send you on your way. The ticking in just the sound of the motor. When suzuki redesigned the motors, they shaved the wall thickness down a bit. More noise is heard now. I've got ove 23k on mine so far with no other problems other than the C28 for two tears ago. the bike still pulls great with 119hp/56 ft-lbs.

If you'd like to clean up your throttle response....do the TRE mod. It will give you back a little power that is robbed by the computer @ lower RPM's. Canadian Gixxer did his 600 and loves it. Give us a shout if you'd like to do it. Its only about $5 in parts and 20 mins. It will may void your warrenty though depending on the issue.
 

·
Resident Banana
Joined
·
2,694 Posts
Definately check out www.gixxer.com ...one of..if not the best gixxer resource site on the web.
 
K

·
Guest
Joined
·
0 Posts
Discussion Starter #10
Thanks atomlowe, my warranty is up in June so maybe after that? Don't want to mess around with it just yet. One thing at a time... :D
 

·
Registered
Joined
·
872 Posts
Canadian_Gixxer said:
my bike is still running. makes that weird noise still for some unknown reason. seems to be coming from the front wheel.

anyhow back to the FI light. I never had a problem with it until the past 3 weeks where it has come on at least 6 times, everytime I shut the bike off and turn it back on it goes off. There was a recall on this I believe, or not a recall but a dealer notice where they replace the STC Unit under warranty because it creates false readings every now and then. I should get take my bike in to get this part replaced.

here is a copy of the bulletin that all suzuki dealers should have got.

http://www.gsxr750.org/images/600/600bulletin/600bulletin1.jpg

http://www.gsxr750.org/images/600/600bulletin/600bulletin2.jpg

thats what you get for cutting up wires on yer bike !
 

·
Super Moderator
Joined
·
5,114 Posts
jonathan said:



thats what you get for cutting up wires on yer bike !
:laughing :laughing

you had your part in cutting my wires :laughing :laughing

oh well, not like the FI light problem is actually any problem, more of just a annoyance every odd time
 

·
Premium Member
Joined
·
11,195 Posts
That's what I like about carbs. They are stupid and don't bother me with things like lights ...... :D
 
1 - 14 of 14 Posts
Top