BC Sport Bikes Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter #1
Earlier today riding to college, I did a really small clutch up wheelie and the bike kinda did something funny (not exactly sure what), but since that it has been riding strangely. It feels different, and the bike randomly stalls sometimes in the middle of riding. It kind of feels like the throttle isn't responding like it should and it doesn't quite have the same power. I'm wondering is it maybe a clogged fuel filter? Something to do with the clutch? Cause when I gear down, it sometimes makes different sounding revs that usual, and when I looked under the bike, there was a little bit of grease coming down from where the gear box is. At least I think thats where it glopped out. Umm.. what else... I don't know, everything feels a little off when I'm riding. The sensation I got when it was about to stall felt like the "i'm running out of gas type of situation" where the bike would no longer let me rev past a certain point, and then slowly revved down until it stalled.

I really have no idea what it is, and I don't really have many people to talk to about it, so I need some opinons of where to start. Or how to diagnose the problem.
 

·
Premium Member
Joined
·
11,195 Posts
First off I'd look at doing all the little things like checking your throttle and clutch cables for proper tension and any binding that indicates that they need cleaning and lubing.

From there I would ask when the last time you did the following was....
-Cleaned out the chain lube goop from inside the countershaft cover (that may well be what the goo coming out the bottom is.
-changed your sparkplugs. Old eroded plugs run badly
-tweaked the idle speed adjustment

It sounds mostly like the bike is just in need of some TLC and a proper tuneup and perhaps a proper carb cleaning. If there's nothing specific you can say other than "it's running funny and stalls now and then" it comes down to a lot of little things that are all ganging up on you most likely.
 

·
Registered
Joined
·
164 Posts
Discussion Starter #4
Thanks for the responses guys, I forgot to come back when I found the solution. It was just a really mucky fuel filter. So I chucked a new one in, and she's as smooth as silk now. Thanks for the help.
 
1 - 4 of 4 Posts
Top