BC Sport Bikes Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I have a Suzuki rf650, my problem is that I am not able to start the bike. When I put the choke on, it makes a pop sound. Can anyone out there tell me why this happens? Thanks to all in advance!!!
 

· Premium Member
Joined
·
11,210 Posts
You're going to need to provide a heap more info to help us out with what's going on.

First off when I google for suzuki rf650 I don't get any returns that are Suzuki related. So right off the bat are you sure about that model designation? Can you describe the bike?

Was the bike running OK before and if so how long ago?
Did this just suddenly happen from one ride to the next or did it degrade over a number of rides or days?
When the starter cranks does it sound fast and healthy or laboured and slow?
DO you store the bike outside (in the recent monsoon) or inside or under a good cover in a dry area?

And feel free to add in anything else you think may have changed from before when it was running OK to now when it's not.
 

· 100% Asshole
Joined
·
3,410 Posts
Can u smell gas from the exhaust?? Is the battery at full charge? When is the last time it ran? See what I'm getting at we need more info if you want us to try and help or take it to a shop. Try FifthGear Bill's not a bad guy and kinda cute nudge, nudge, wink, wink...........
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top