BC Sport Bikes Forum banner
1 - 6 of 7 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #1 ·
Hey guys,
I am going to be doing some minor servicing to my bike this weekend and i had a few questions about some things i want to work on.

Here's what i want to do:
Change oil (filter + oil)
Clean Air filter
lube chain
tighten clutch cable (The clutch level is a bit loose due to a loose cable)

With these things in mind, do i absolutely need a bike stand to do all of these? can any be done without?

Is the stock Air filter on an 09 ninja cleanable? or do i have to just replace it? if so where is the best place to go for a new one?

Where should i get a new oil filter and oil from, and what oil filter and oil should i get?

What kind of lube do i use for the chain and where is the best place to get it?

And finally how do i go about tightening the clutch cable? my clutch level is pretty loose..

Oh and where should i go for a bike stand as i eventually want to get one, and how much are they? :S


Even if you can only answer one or two of these questions it is greatly appreciated =D

Thanks in advance.
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #9 ·
Thanks for all the suggestions guys.
I am not worried about my ability to do these tasks as i am pretty decent with car maintenance already so this should be not problem. I just wanted to to be sure of everything and gather opinions and data from all available resources first to be sure, as this is my first time doing any sort of 'bike' maintenance.
As for the manual I managed to download one online :p
Looks like I'll be hitting up EMS, and Canadian tire =D
Thanks for the large amount of input all! Looks like its gonna be a fun Saturday taking care of my baby!!
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #15 ·
Wow! i am definitely going to msg that guy about the cheap bike stand =D
Went to Canadian tire this afternoon and found a bottle of WD40 and a bottle of PJ blue label chain lube as well as a pack of steel (or whatever)bristle brushes.
Then about 20 min ago i went at er' in my buildings parking garage. (just a word of wisdom for others who haven't done this before, I suggest doing it in a 'well' ventilated area as that PJ lube stinks!) It was no problem to do the entire chain with no stand and only took about 15+ min to do ^__^ tomorrow its onto tightening up the clutch cable (took a look in the manual and it looks like this wont be too big of a problem to accomplish)
Thanks all for the awesome help and input!
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #17 ·
Ok so I currently just have one more item to ask about.
I get this lovely sqeaking noise from my front tire all the time!
I don't think its the breaks cause breaking and not breaking don't affect it, however sometimes the noise will go away and sometimes it comes back for no reason, also it doesn't happen at very slow speeds but becomes more noticeable at higher speeds. I heard that it might be the odometer cable? (the one on the left side of the tire, and that i should grease that, any one know a grease that Canadian tire has that i should get for this? If greasing this piece doesn't make the squeak go away where should i look next?
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #20 ·
The cable's coming from the factory too dry or just plain old DRY. It's stripping the plastic gear in the hub and eventually....the back of the guages where it mounts. I've had to order two guages for customers already. Get the cable off....strip and grease it... reasseble and put grease in the hub portion as well.

As a matter of policy, we are doing this on the PDI on all 250 Ninja's now and anyone that comes in for service. Takes about 10min to do.:2cents
How much does it cost to get that done?
 

·
Registered
Joined
·
91 Posts
Discussion Starter · #21 ·
so i went to the guys at EMS (they are awesome btw) and they took out my speedo cable and cleaned and greased it. I took the bike for a short drive with the cable out and noticed that the squeek went away. Once it was greased and put back in the squeek came back.. so now i assume its in the back of the actual speedo gauge... Anyone ever get this serviced before? is this gonna cost me an arm and leg?
 
1 - 6 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top