BC Sport Bikes Forum banner
21 - 23 of 23 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter · #21 ·
so i went to the guys at EMS (they are awesome btw) and they took out my speedo cable and cleaned and greased it. I took the bike for a short drive with the cable out and noticed that the squeek went away. Once it was greased and put back in the squeek came back.. so now i assume its in the back of the actual speedo gauge... Anyone ever get this serviced before? is this gonna cost me an arm and leg?
 

·
Registered
Joined
·
163 Posts

·
Premium Member
Joined
·
11,196 Posts
Two points I noticed among all the posts.

First, DO NOT use a brush with any sort of metal bristles to clean your chain. If it's an O ring chain the metal bristles will chew up the Orings and quite likely damage them and allow water in and the lubricating grease out. Stick to plastic bristle brushes that are similar to tooth brushes.

Secondly your clutch cable. There DOES need to be a little bit of light play at the lever. It needs that bit of slack to ensure that the clutch plates are fully engaged. There's a light return spring in the lever or at the base of the engine and you can feel that in the lever when you first pull and then after a small amount of movement you will then feel the actual resistance of the clutch springs themselves. The amount of "slack" you have should be roughly a 1/2 inch or 1cm of movemnt at the ball end of the lever before you feel the clutch lever tighten up. Do not adjust the cable so that it is any less than that.
 
21 - 23 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top