BC Sport Bikes Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1,070 Posts
Discussion Starter #1
Well Human was supose to be meeting me at my place at 5 to help me with the flush mounts and he is normally early and as of now he is 35 minutes late. This would have been his first day on the bike with it insured so I hope he didn't wreck somewhere in all this rain :confused
 

·
Super Moderator
Joined
·
5,114 Posts
Ryan R said:
Well Human was supose to be meeting me at my place at 5 to help me with the flush mounts and he is normally early and as of now he is 35 minutes late. This would have been his first day on the bike with it insured so I hope he didn't wreck somewhere in all this rain :confused
that would suck.... :(
 

·
Registered
Joined
·
1,070 Posts
Discussion Starter #3
Its now been over an hour and no call or sign of him, I am starting to get worried. Dont let this be the horror story to start the season off. :confused
 

·
Premium Member
Joined
·
20 Posts
Traffic is REALLY bad out there man.. I don't know where he's coming from, but the East/West Connector was backed up all the way to Richmond.s
 

·
Registered
Joined
·
1,070 Posts
Discussion Starter #5
He is coming from langley and I live at 8th ave and 184th about. Takes him 15 minutes to get here. But he also said he was going to swing by and grap the lights for me from BK so maybe he got stuck in traffic. I hope that is what happend.
 

·
Super Moderator
Joined
·
5,114 Posts
any sign from him? I just got back riding from school.... it's pretty messy out there, surprisingly slick for a wet day....
 

·
Resident Banana
Joined
·
2,694 Posts
Good to hear it....it looks nasty out there.
 

·
Just Another Enthusiast
Joined
·
2,051 Posts
Good to hear that Human is OK. My ride home from school was interesting, the roads are a little slick and the wind is pretty strong in the flats. It really gusted on 64th between 152 and 168, I had to LEAN into the wind a few times. But other than a little mud, the bike is fine. :)
 

·
Registered
Joined
·
4,209 Posts
hi guys, thanks for the lookout folks, love ya all.....ya sorry I got messed up....


well first I got stuck in the west bound traffic before the portman then on Canada way on my way to BK then again east bound on hwy1 before the portman, too kthe 152 st exit to go all the way to 8th ave. for Ryan's place, eneded up at the water, took a right then later made a u-turn then somehow ended up at the canadian-US border, managed to get back onto 8th ave, after getting instructions from border guards, from there took 2 minutes to get to Ryan's place....

i forgot my PDA at home so didn't have Ryan's number with me and I don't know his last name or his dad's name to look up in the phone book.


Well I got throughly soaked, very cold, I have setup my suspension too firm, got a headahe thanks to the rough roads, but otherwise put in 136.4 kms....good start, love the yosh pipe, beauty sound, not too loud not too quiet, perfect....though I know have a flat spot between 5,000-5,500 rpm and again between 8,000-9,000 rpm....
 
1 - 12 of 12 Posts
Top